Таблица значений в массив структур

Таблица значений в массив структур

Данная процедура Преобразует таблицу значений в массив.

Может использоваться для передачи на клиента данных, полученных на сервере в виде таблицы значений в том случае, если таблица значений содержит только такие значения, которые могут быть переданы на клиента

Полученный массив содержит структуры, каждая из которых повторяет структуру колонок таблицы значений.

Не рекомендуется использовать для преобразования таблиц значений с большим количеством строк.

Начал программировать в 8.2 и столкнулся с постоянной проблемой передачи "таблицы значений" в Управляемую форму ну и написал маленькую функцию конвертации ТЗ в Массив с вложенной структурой.

Функция ТабЗначВМассив ( ТаблицаЗначений ) Экспорт
НашМассив = Новый Массив ;
Для Каждого СтрокаТаблицы из ТаблицаЗначений Цикл
НашаСтруктура = Новый Структура ;
Счетчик = 0 ;
Для Каждого СтрокаСтруктуры из СтрокаТаблицы Цикл
Если НЕ ТипЗнч ( СтрокаСтруктуры ) = Тип ( ТаблицаЗначений ) тогда
НашаСтруктура . Вставить ( ТаблицаЗначений . Колонки [ Счетчик ]. Имя , СтрокаТаблицы [ Счетчик ]);
Иначе
НашаСтруктура . Вставить ( ТаблицаЗначений . Колонки [ Счетчик ]. Имя , ТабЗначВМассив ( СтрокаСтруктуры ));
КонецЕсли;
Счетчик = Счетчик + 1 ;
КонецЦикла;
НашМассив . Добавить ( НашаСтруктура );
КонецЦикла;
Возврат( НашМассив );
КонецФункции

Задача. Получить данные из таблицы объекта, поместить эти данные в параметры оповещения
для открываемой формы. Загрузить эти данные в таблицу открывшейся формы.

Получение данных. Данные решено было поместить в массив структур. Структура описывает данные строки таблицы значений.

Получение данных из массива запись их в таблицу значений

Специальные предложения

Часто требуется перекидывать не только на сервер, но и на клиент.
На клиенте ТЗ недоступна

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).

А способ автора — сто лет в обед

(20). Может, и есть какие либо другие решения, но мне не попадались, да и искать не захотелось. Накидал по-быстрому свой вариант.

Читайте также:  Столбец электронной таблицы это

Читай аннотацию, а не ерничай.

ну еще много ссылок в комментах

Да и мееседж был к (5), не к Вам

(20) Ну так вопрос "Как получить ТЗ на клиенте" в принципе не корректен, т.к. ТЗ на клиенте не существует. Сперва нужно определится зачем таблица на клиенте, затем определится где ее хранить, а уже затем — как ее получить. Почти всегда это заполнение таблицей значений на сервере реквизита формы или объекта. Иногда нужно и преобразование в массив структур или структуру массивов, например для конвертации в JSON. Но первично — определить, а во что положить то на клиенте.

Для задачи передачи ТЗ через клиент — лучший вариант через временное хранилище, но он не единственный и бывают ситуации, когда можно обойтись другим подходом. Именно про это я и говорю в (5)

(24)У меня задача стояла именно прокинуть ТЗ через клиента. Об этом и писал в самом начале.
И ни слова о том, что ее нужно получить на клиенте. Все остальное не мои додумки. 🙂

. Как передать таблицу значений через клиента.

Если простые типы, то и JSON можно использовать

См. также

Таблица значений. Нюансы 213

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019 12593 Yashazz 36

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

Ссылка на основную публикацию
Adblock detector